Can't get the Maxx to communicate with PC

This topic contains 15 replies, has 2 voices, and was last updated by  matte 2 weeks, 2 days ago.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #30465

    matte
    Participant

    Hi, I’m having trouble getting my KNK Maxx to communicate with my Windows 10 PC. I followed the instructions I found in some other forum posts, like installing the D2XX drivers and directing software to the correct COM port, but when I send a cut file or even a connection test, nothing happens. Should I see the device listed as a KNK Maxx in my connected devices? Currently it looks like Windows sees it as  “FT232R USB UART”. Any advice to help get this set up would be a big help. Thanks!

    #30469

    Sandy
    Moderator

    Seeing it listed as FT232R USB UART should be fine.   What model do you own?  What software are you using?

    #30472

    matte
    Participant

    Thanks for the quick reply! I’ve got the KNK Maxx, 24-inch model. I have a copy of Make the Cut, which I’d like to use since I’m familiar with it. The person who sold it to me also included a disc with ACS Studio on it, but I’m not interested in using that if I don’t have to.

    #30474

    Sandy
    Moderator

    Three things to check:  in MTC, make sure you have the correct Maxx model selected.  Secondly, make sure the Com Port selected in MTC matches what is shown in Device Manager under Ports.  Thirdly, make sure the Baud Rate on the Maxx itself matches what you’ve selected in MTC.

    #30482

    matte
    Participant

    Hm, I checked the model (and even tested using the incorrect models), selected the correct Com Port (and even tried changing it to a different one in the advanced Device Manager settings) and confirmed that the Baud Rate is correct (didn’t want to fiddle with that, as I don’t really understand it).

    I’m going to see whether it works on a different computer, just to rule out any problems with the machine, but I would ultimately like to get it working with my main computer. Any other suggestions?

    #30491

    matte
    Participant

    Still trying to get this working, though I found something that may be useful in diagnosing it:

    I tried sending some cut data while the machine was in offline mode, and the MTC progress bar said, “Flushing buffers. Waiting for KNK machine”. When I switched the machine back to online mode, the progress bar moved and the coordinates were sent, however the machine still did nothing. I tried using the “repeat” button on the machine, to cut the last data sent, but the screen said “no data”.

    So it would seem that the computer is recognizing the machine, but the machine isn’t accepting the data that’s being sent to it?

    #30494

    Sandy
    Moderator

    Let me think on it some more.   Checking on a different computer is definitely a good idea.

     

    #30495

    matte
    Participant

    I was only able to get to the same point with the other computer: recognizes that the device is plugged in, MTC points to the correct model, baud, and com port, but nothing happens when the cut data is sent. On both computers MTC can tell whether the machine is in offline mode, but the machine is unresponsive to anything the computer tries to send it (connection test, cut data, or laser alignments).

    I’ve also requested support via the KNK site, but still waiting to hear back from them.

    #30496

    matte
    Participant

    Looks like it’s a similar issue to this thread:
    https://knkusa.com/forums/topic/no-communication/

    But there was never a solution posted. And my machine is definitely just the Maxx, I checked in the menu and didn’t find any bluetooth.

    #30504

    matte
    Participant

    Hooray! I figured it out!

    There are actually three places to that need to be set to 57,600, not just two. I had the machine “br” set to 57,600 and in Make the Cut I had the Baud Rate set to 57,600, but it turns out the settings of the Com Port itself were only set to 9600. Once I changed that, everything worked great.

    For other folks who might be stuck, go into your Device Manager, open your USB Serial Port (COM*) properties and go into Port Settings. Make sure that the Bits Per Second are set to 57,600, or matching whatever your other settings are.

    It only took me an entire day, but I am fully operational! And now I know that br, Baud Rate, and Bits Per Second are all related terms.

    #30506

    Sandy
    Moderator

    That’s fascinating… simply because the software is supposed to ALWAYS override the setting in Device Manager and has always done that (for years) up until now!  lol I’m so glad you figured that out.  I’ll note this in my tech support database as another thing to check. Thanks for posting back and feel free to post again with any other questions or issues.

    #30519

    matte
    Participant

    Well, maybe I spoke too soon… I shut things down and when I came back later to show off, it was back to not working. Rrgh. I don’t remember what else I had done that might’ve temporarily fixed it, but I submitted a support ticket with KNK this morning, so hopefully they can help me out soon. At least it was mildly encouraging to see it work for a few minutes.

    #30520

    Sandy
    Moderator

    The fact that it DID work eliminates a lot of possible causes. Hopefully KNK will have the solution but I will also check my tech support notes to see if I might have missed something else.

    #30546

    matte
    Participant

    Yeah, it’s still frustrating but at least I know it could work eventually! Do you happen to know how quickly KNK typically responds to support tickets? I submitted one yesterday morning, but haven’t heard anything from them yet.

    #30561

    Sandy
    Moderator

    What is your ticket number? I can check on it for you.

    • This reply was modified 2 weeks, 2 days ago by  Sandy.
Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.

Pin It on Pinterest

Web Statistics