KNK Element and Windows 10

This topic contains 21 replies, has 3 voices, and was last updated by  Sandy 1 day, 14 hours ago.

Viewing 15 posts - 1 through 15 (of 22 total)
  • Author
    Posts
  • #35958

    chrishogg27
    Participant

    I have a white KNK Element that I am trying to set up with windows 10.  I have installed the KNK Studio Version 8 and followed the installation directions.  Program loads up but when I go to cut I get “ERROR LOCATING SECURITY DEVICE: 1”  Looking for help.  Thanks

    #35960

    Sandy
    Moderator

    That message means it’s not locating the dongle.  So, first off, make sure you have installed the driver for the dongle.  That can be downloaded from here. Unplug the dongle, install the file, reboot Windows, wait for Windows, install the dongle, open the software and then try again.

    http://www.iloveknk.com/Support/Drivers/Klic-N-Kut/Dongle/

    Then, make sure the correct license files for YOUR dongle are in the Klic-N-Kut folder on your C Drive. Are you following instructions posted somewhere?

     

    #35961

    chrishogg27
    Participant

    Thank you – it is working now – just didn’t have the driver for the dongle I guess.  Appreciate your help!!!

     

    #35964

    Sandy
    Moderator

    You’re welcome! I was hoping that was the issue.  🙂

    #35967

    chrishogg27
    Participant

    Will my machine work with Sure Cuts A Lot 5? I have downloaded the trial version but haven’t been able to get it to cut.

     

    #35975

    Sandy
    Moderator

    With the Element hooked up to your computer and turned on, go to Windows Device Manager and open the Ports folder. Check to see how the Element is listed. If you see the letters CH341, then it’s the original Element and you’ll need some different cables (see below).  If it says USB-Serial COM X then your Element SHOULD be working from SCAL.  In the Cut Settings window, do you have XL selected as the Model?  That’s what you need to use.  Then click on the Settings button in that window and verify that the Baud Rate is set to 9600.   Try again by clicking on the Test Connection button.  See if the same Com Port you’re using from KNK Studio is also listed in the drop-down menu if Auto isn’t working.

    If you still can’t get a response, then note that the earliest Elements, like mine, had a different kind of USB connection on the mainboard (or whatever). I’m not the best at explaining this, but when we were first testing the Element with Make The Cut (MTC) software, mine wouldn’t work but the remaining ones that KNK USA still had did work. The owner of MTC and Chad at KNK figured out the issue.  Chad remembered that the early Elements were different and connected using a different kind of driver.  Well, the same thing applies to Sure Cuts A Lot (SCAL).  There’s one way around it… you need an RS 232 serial cable PLUS an RS 232-to-USB converter cable. If you hook up those two cables and then attach between your Element and computer, then a regular FTDI driver can be installed that will work with MTC and SCAL.

    #35991

    chrishogg27
    Participant

    CH341 showed up.  I have just ordered the cables you suggested.  Thanks again!

    #35995

    Sandy
    Moderator

    You’re welcome! Post back if you still have problems getting the cutter communicating.

    #36051

    chrishogg27
    Participant

    Hey Sandy,

    My RS232 cable arrived today.  Do you have a link to the FTDI driver that I will need?

    Thanks

    Chris

    #36056

    Sandy
    Moderator

    Here’s the link:

    https://www.ftdichip.com/Drivers/D2XX.htm

    Click on Setup Executable in the Comments field to get the file to install.  I recommend waiting to plug in the Element.  Install the driver and reboot Windows. Wait for Windows and then plug in the cutter.  Then check the Ports folder for a Com Port assignment. You dont’ need the number for SCAL to find it.  But it helps to know that for sure it now says USB-Serial COM X before attempting to use SCAL.

    #36061

    chrishogg27
    Participant

    Hi Sandy,

    So here is where I am at; I have the rs232 serial cable and usb adaptor connected to my cutter.  Installed the downloads, restarted windows – showing “Prolific USB-to-Serial Comm Port (Com7)

    Opened SCAL5 Cut settings; Model XL, Connection USB, Port Auto Detect, Baud 9600

    I have tried the test connection and got nothing, I tried text and cutting and got nothing.  Not sure what I am doing wrong.  Any other advice to try?

    Thanks,

    Chris

    #36078

    Sandy
    Moderator

    Did you try selecting COM7 from the menu instead of using Auto? Does it appear there?  Also, did you test the connection from KNK Studio? It seems you still have it based on your original post, yes? That will at least tell us if the cable connection seems valid for communication.

    #36079

    chrishogg27
    Participant

    I did try selecting COM7 from the menu – it did appear and I tried both auto and selecting.  I just tried cutting from Studio and still nothing.

    #36085

    Sandy
    Moderator

    But just to verify… after you got the dongle issue resolved, you were able to cut from KNK Studio using direct USB, right?  Or did it never work from either software program?

    #36086

    chrishogg27
    Participant

    I did get it cutting with KNK Studio and the USB cable – so no problems there. Would love to be able to use the SCAL program though.

     

Viewing 15 posts - 1 through 15 (of 22 total)

You must be logged in to reply to this topic.

Pin It on Pinterest