KNK Force firmware

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #47662
    areswolfblitz
    Participant

    Will the firmware for this ever reach 1.0 or be completed?

    #47663
    Sandy
    Moderator

    The developer of C3 is an independent company and is not interested in any further development of C3 at this time.  This was very disappointing to us given the list of features that had originally been requested and never added.

    If you are having any difficulties with your Force, please feel free to post what they are. Our Force Facebook group remains active and a lot of information and ideas get shared there.  Perhaps I can provide some solutions for you.

    #48301
    Shannon
    Participant

    Hi Sandy and Forum Participants,

    I have a KNK Force that is unfortunately not booting up cleanly.  When powering on I get the expected light show, but after 70 seconds the Force finishes booting with a red flashing light.  With a quick press of the power button, the Force then illuminates with a solid white light.  I can connect to C3 using Chrome and the firmware was at 0.5.40.  I updated the firmware to 0.5.57 which the C3 interface confirms.

    If I try to set a tool or send a design using either C3 or SCAL (latest update of version 4), the red flashing light comes back on.

    I did reseat the SD card in the Force, but nothing changed.  I did read about reseating the connector inside the right side panel, but before trying this would appreciate your thoughts.

    Thanks in advance for any advice/assistance!

    Shannon

    #48303
    Sandy
    Moderator

    I will need to check with Chad or the factory regarding a red flashing light.  I only know that a continuous blue flashing light means the SD card probably needs to be re-flashed.

     

    #48304
    Shannon
    Participant

    Thank you Sandy for looking into this.  Look forward to any information!

    Kind Regards,

    Shannon

    #48305
    Sandy
    Moderator

    I haven’t heard from Chad but I shared this with Paul Zingah, my long-time cutter colleague and fellow Force supporter and he responded with the following:

    I have this vague memory of the wrong colour light and it being the connection to the light strip. If the machine otherwise works apart for the wrong light, that could be it.

    Another stab in the dark; Load another svg file via C3. I seem to recall having issues when I loaded a flawed svg.

     

    #48306
    Shannon
    Participant

    Sandy, let me reiterate that the Force no longer works.  Each time I  boot up the unit the process ends with a red flashing light.  If I quick press the power button, the light goes to solid white (ready mode).  As soon as I try to do anything with the Force, the red flashing light comes back on.  I can go into either C3 or SCAL and and say try to load a tool or to test connection (SCAL) and the flashing red light occurs.

    I thought that perhaps updating the firmware to 0.5.57 might solve the issue, but unfortunately not.  I am able to see the KNK Force WiFi connection on my computer and after connecting to it, I can open C3 and browse the three tab pages.

    It’s not a SVG (design) issue as again, I cannot load a tool or even move the head to the origin point without the red flashing lights appearing.

    I did reseat the SD card and the issue remains.  I am not opposed to shipping the unit to get serviced and understand there could be a charge.  I just hope to get the Force to work again as it was quite an investment and used perhaps 2 hours total.  I have a Silhouette and a KNK Zing that I use without issue.

    By the way, THANK YOU for taking the time and effort to be of assistance.  In today’s world, kindness is appreciated and should be acknowledged!

     

    #48308
    Sandy
    Moderator

    Plotter Geeks now handles diagnoses and repairs of KNK cutters.  Here’s the link to their contact page:  https://plottergeeks.com/contact/

    You can also submit an RMA since it sounds like your Force will need a repair… or wait. Either way, here’s the link and instructions or that:

    https://plottergeeks.com/rma/

    I urge you to post back or PM me on FB once you’ve completed this form so that I can follow up with them on your behalf.  🙂

     

     

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.

Pin It on Pinterest