KNK Maxx revival, trying to make it work in 2020

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #47929
    leonardo
    Participant

    Hi there!

    I’m trying to use a knk Maxx that haven’t used in years!

    I got Mac OS Mojave and installed the Sure Cuts a Lot trial to check if it works,

    Connected with usb but I notice that a red blinking led is all the time, I tried to move x y and

    restart but is always the same red. Also tried to send a cut but nothing happens.

    Is there something I’m missing?

     

    Thanks in advance!

     

     

    #47930
    leonardo
    Participant

    Ok seems I make it work, just writing here for anyone on the same situation:

    I avoid the red led blinking by reseting the cutter:

    1. Turn off the cutter.
    2. While pressing the origin button (the one with a sight symbol), turn on the cutter and hold until you see Reset on the display.
    3. This will reset all settings back to factory default.

    Then I found out thanks to Sandy MC reply here:

    https://forum.make-the-cut.com/discussion/31358/newbie-not-getting-communication-knk-maxx-with-make-the-cut

    That I have the Knk Maxx Air! Even if it doesn’t have the title in it.  That did the trick to communicate the cutter to the mac (using a PC emulator), cause I used just Maxx alone before, thinking it was that model!

    Now will try to see if I can cut something…

     

    #47932
    Sandy
    Moderator

    Post back if you have any issues getting it to work.  I will be happy to help you.  You can also email me at smccauley45@cox.net.  Oh… and my MaxxAir support page is here:

    KNK Maxx Air Support Page

     

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.

Pin It on Pinterest