KNK Zing Orbit Not Turning On

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #47643
    Ellen
    Participant

    Hello! I have a Zing Orbit and it turned off in the middle of a cutting session and now won’t turn back on. I thought it might be the power supply, but I replaced it and no luck. It makes an electrical whining noise when I push the power button. I haven’t been able to find anything online about a solution to this. Anyone have any idea?

    I put in a support ticket in May but have not received a response as of yet. I submitted another one today.

    I’d really like to be able to use my machine 🙂

    #47645
    Sandy
    Moderator

    Did you replace the power supply with one purchased from KNKUSA?  You can’t necessarily use anything that seems like it will work. In fact, it can severely damaged the cutter if the specs are not identical.

    #47646
    Ellen
    Participant

    Hi Sandy,

    Thank you for your reply! Yes I bought my replacement power supply from the KNK website. This one:

    85225DF5-A29B-4989-8076-73026E438B80

    #47651
    Sandy
    Moderator

    I contacted KNK USA but I don’t see a response here yet. If you hear anything directly via email, please post back. Also, the email will probably come from Plotter Geeks instead of KNK USA, so check for that… also in your spam folder.

     

    #47659
    Chad Youngblut
    Keymaster

    Hi Ellen,

    I see you received my email and also created and RMA. We’ll keep an eye out for your machine and get you squared away.

    Take care!

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

Pin It on Pinterest