KNP3d flexible feet

This topic contains 18 replies, has 2 voices, and was last updated by  reallygroovy 5 months ago.

Viewing 4 posts - 16 through 19 (of 19 total)
  • Author
  • #23807


    hi darrel,

    thanks for the response!  i’m probably not clear in my question to you.  i can type the command in the terminal window and it will work.

    in slic3r, however, in the print settings tab, there is post-processing script box.  i guess i was assuming that if i type that same command in that box, the code would execute.

    in the manual, sandy typed a command for windows (the path to the knp3d converter) which supposedly would bring up the knp3d converter.

    i don’t believe i have a permissions problem, but, i did change them anyway so everyone could read and write.  it still doesn’t work.  i even put the path in it as well.  perhaps, this feature for MAC does not work.  maybe it only works for windows as the knp3d converter was created by MTC and i understood that andy was not a mac programmer.  would make sense also because there is only one example for the post processing script entry as windows, normally, there are examples for windows and mac versions.

    also, i’m assuming the flexible feed are only for decorative purposes.  in my setup, i have to constantly turn the knp3d to change the filament or troubleshoot.  too bad it didn’t specify that they were for decoration as nothing sticks to silicon.  kind of frustrating though, when i try different things, however, my vision of the end result will not come to fruition.  manual should say it doesn’t work for mac and i wouldn’t have worried about it.  also for the feet, indicating that the feet are silicone so the user would be unable to adhere any adhesive or glues to the machine.

    thanks for you help darrel!


    Darrel Farris

    If you type the command in a terminal window and it works, then great. That command should then be added to a text file and saved as <something>.sh.  The path to that file, which is now a script, is what you put in to slic3r.





    thank you darrel. i respect your clarity, knowledge and input for that is very important to me.  and you are right about me referencing ios as incorrect. i really meant that my mac has an older os 9.1.3.   i am going to check my permissions again and see if i overlooked something.  i am familiar with using command lines and programming. consequently, it did not seem logical to me that inputting that command line in slicer did not work for me.  it also didnt seem logical to me that the feet were so flexible that they would not stay on the machine. i understand its purpose, but in the case when a user needs to turn the machine to get to the filament, it is impossible with the feet i have as they slip right off. and then having to level the build plate again is a pain.

    but of course, there are workarounds to any situation. if things are possibe, i am all in, if it isnt then i know i need to just work it out. again, thanks darrel, you are an asset to knk and really appreciate you! as i do and will continue to peruse for help. now off to permissions land……



    hi darrel,

    last comment! thank you, thank you, thank you! by george it worked! your instructions were very clear, however, it is me that tends to suffer from serious brain freeze! ughhh! anyway, to make a long story short, i didn’t realize that there were spaces before the command i had input in the post processing scripts.  after i deleted the command i had typed and then ran slic3r, it indicated that i had a permissions problem, but, i saw nothing out of the ordinary.  so i put my curser in the box and started backspacing and of course there were blank spaces.  once i typed the code in without the spaces, it worked.  gee, what a learning experience! lol. but, as i said before darrel, your technical experience, background, and your ability to teach those who need help is what makes the customer experience great!  thank you for your responses and for putting up with me, who by the way should have gotten it the first time, but unfortunately, my brain sucks and tends to over analyze the simplest of things.  also, from your explanations about the feet, i was able to move on, make 3d feet, use the force to cut out felt for the feet, and wala! – mission accomplished!! toodles!:)

Viewing 4 posts - 16 through 19 (of 19 total)

You must be logged in to reply to this topic.

Pin It on Pinterest

Web Statistics